[Wine] Run 32-bit Google SketchUp in 64-bit Fedora 12?

owlbrudder wineforum-user at winehq.org
Tue May 4 19:52:54 CDT 2010

I am running Fedora 12 x86_64.
I want to run SketchUp, which reportedly works under Wine.
What I did:
yum install wine
Download GoogleSketchUpWEN.exe
run "wine GoogleSketchUpWEN.exe"
The yum install successfully installed wine-1.1.38. I have an executable script '/usr/bin/wine' and two executable binaries '/usr/bin/wine32' and 'usr/bin/wine64'. The script seems to end up invoking /usr/bin/wine64 whenever it is called, but I am not a script expert.
The GoogleSketchUpWEN.exe installer appeared to work - it brought up GUI dialogs and offered to install in C:\Program Files etc, just as I expected. It also generated a menu entry for SketchUp under "Applications/Wine/Programs/Google SketchUp 7/".
The menu item does not launch SketchUp. The command associated with this menu entry is 
env WINEPREFIX="/home/doug/.wine" wine "C:\Program Files\Google\Google SketchUp 7\SketchUp.exe"

If I run this command in a terminal, or if I change the command to explicitly run wine64, I get the response: 
wine: '/home/doug/.wine' is a 32-bit prefix, it cannot be used with 64-bit Wine.

If I change the command so it explicitly runs wine32, I get a raft of complaints about missing dlls, such as 
err:module:import_dll Library MSVCP80.dll (which is needed by L"C:\\Program Files\\Google\\Google SketchUp 7\\DD_Ge_2.04_8.dll") not found

I have not tried to download or run the winetricks script - I'm not even sure if it can help in this case and I am wary about the warning that running it 
> may limit your ability to get support though WineHQ

I have in my home directory .wine/ and .wine-x86_64/. The SketchUp app has been installed into .wine/.
This is the first windows app I have tried to install. I am a relative newbie to Wine, but not to Linux.
I am sure there is something simple that I am missing. What am I doing wrong?

More information about the wine-users mailing list