[Wine] Metatrader Installation error

msnomore wineforum-user at winehq.org
Sat May 8 19:19:40 CDT 2010

I am experiencing a problem with the installation of Metatrader4.

The problem is that at the end of the installation I receive an error message:
'Error changing registry data'. The system then proceeds to carry out a roll back routine.

I have previously managed to complete this on a Sony Laptop running Ubuntu 9.10 (Karmic) with Wine 1.1.42. Wine has since been updated to 1.1.43 and Metatrader still works, having been previously installed.

However, I have since tried on another PC system with the same software releases with the error result above (initially Wine 1.1.42, then 1.1.43). I have also installed Ubuntu 10.4 (Lucid) on this PC and have the same result. The PC is running the 64 bit version of Ubuntu, so in case this might be the problem, I have also tried the 32 bit version (albeit installed as a Virtual Machine). In both cases, the MFC42.DLL file was present and I have run (installed) both 'winetricks' and 'corefonts' in both environments.

Interestingly, when I first tried the installation on this system, I believe it actually installed but then failed to run, with an error regarding MFC42.DLL being missing. I can't remember what I did, but when I then tried to re-install it, I then received the registry update error message, and have done ever since with 9.10 and 10.4 (64 bit) and 10.4 (32 bit) via VM.

On the Sony system, where I have it installed successfully, I did install 'winedoors' but then un-installed this. I don't know whether something was 'left behind' that enabled the installation to complete.

I would be grateful if anyone has any ideas on what might be causing this, or what I can try.

However, I reiterate that I do have MFC42.DLL present. So unless there are different versions of this, then the lack of this library is not the problem.

Thanks, in anticipation.

More information about the wine-users mailing list