[Wine] Multisim not installing

F_style wineforum-user at winehq.org
Thu Nov 4 20:22:01 CDT 2010

Hi. Now I'm trying to install Multisim, and tried with both 10.1 and 11.0 with the same errors. Just when executing the installer it throws an error message regarding something like "error msi 1623",but the Wine log is:

User at linux-e9or:~/Downloads/Multisim 10> wine setup.exe
fixme:volume:GetVolumePathNameW (L"Z:\\home\\User\\Downloads\\Multisim 10\\Supportfiles\\resource_eng.cab", 0x65b380, 66), stub!
fixme:volume:GetVolumePathNameW (L"Z:\\home\\User\\Downloads\\Multisim 10\\supportfiles\\nipie.exe", 0x65d588, 59), stub!
fixme:ver:RtlGetProductInfo (6,0,0,0,0x32f7a0): stub
fixme:volume:GetVolumePathNameW (L"Z:\\home\\User\\Downloads\\Multisim 10\\supportfiles\\NISysInf.dll", 0x6666e0, 62), stub!
err:ole:CoGetClassObject class {5b9cece7-5b14-44da-a00b-d38c3c97fe66} not registered
err:ole:CoGetClassObject class {5b9cece7-5b14-44da-a00b-d38c3c97fe66} not registered
err:ole:create_server class {5b9cece7-5b14-44da-a00b-d38c3c97fe66} not registered
fixme:ole:CoGetClassObject CLSCTX_REMOTE_SERVER not supported
err:ole:CoGetClassObject no class object {5b9cece7-5b14-44da-a00b-d38c3c97fe66} could be created for context 0x17
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:advapi:LookupAccountNameW (null) L"User" (nil) 0xa8d5e8 (nil) 0xa8d5ec 0xa8d5e0 - stub
fixme:advapi:LookupAccountNameW (null) L"User" 0x11d5900 0xa8d5e8 0x11d45b8 0xa8d5ec 0xa8d5e0 - stub

So tried installing msi2 with Winetricks, and now error message says there's another app running and must be closed before installer can proceed. Wine log is:

User at linux-e9or:~/Downloads/Multisim 10> WINEPREFIX=~/winetest wine setup.exe
fixme:volume:GetVolumePathNameW (L"Z:\\home\\User\\Downloads\\Multisim 10\\Supportfiles\\resource_eng.cab", 0x65b3d0, 66), stub!
fixme:volume:GetVolumePathNameW (L"Z:\\home\\User\\Downloads\\Multisim 10\\supportfiles\\nipie.exe", 0x65d580, 59), stub!
fixme:ver:RtlGetProductInfo (6,0,0,0,0x32f7a0): stub
fixme:clusapi:GetNodeClusterState ((null),0x33f828) stub!
fixme:advapi:DecryptFileA "c:\\3521bc0737547436808a1282bace\\" 00000000
fixme:setupapi:pSetupGetGlobalFlags stub

Even tried Multisim with CrossOver, who gives error of Internet Explorer 4 or newer to be missing. I think it could be the same msi-related error as in Wine. I know there were some few threads about this before, but unresolved. Besides Multisim seems to be marked as silver. What can be happening? Is there yet a solution or workaround? Thanks.

More information about the wine-users mailing list