[Wine] Re: 1.3.7 wine for Ubuntu 10.04

lomaxfalconer wineforum-user at winehq.org
Fri Nov 19 13:57:35 CST 2010

also adding i am running x64 Ubuntu 10.4 and have never compiled anything in my life, getting error following your instructions

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for cpp... cpp
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

So looked up how to make 32 bit wine under X64
and did   sudo apt-get build-dep wine

And got error

The following packages have unmet dependencies:
  lib32ncurses5-dev: Depends: lib32c-dev
  lib32z1-dev: Depends: lib32c-dev
  libsane-dev: Depends: libsane (= 1.0.20-13ubuntu2) but 1.0.21-0ubuntu1 is to be installed

this is why i like the package installer :(

More information about the wine-users mailing list