[Wine] Fedora 14 --> strange graphics issues.

Ianw wineforum-user at winehq.org
Sun Nov 21 15:36:28 CST 2010

I just upgraded from Fedora 11 to Fedora 14, and now I'm getting strange problems with graphics in multiple games that make me wonder if something is fundamentally broken: 

1) I run world of warcraft full-screen at 2560x1600. Everything works fine, frame rate is high, etc. Then I switch workspaces and switch back, and now only the center 2048x1280 (estimated) is displayed, and my desktop is visible (and can be interacted with past the edge of that 2048x1280 window). The game thinks it's still running at 2560x1600. It's not resized, a good chunk is no longer visible, it's just only showing the center part of the screen.

2) Did I say everything worked? No, the 

3) Diablo II -- the D2VidTst program no longer detects that the system can run Direct3D or DirectDraw. However, if I edit the registry entries to force the use of either, it works fine. I was using a glide3d.dll wrapper, but that no longer works with this upgrade -- no graphics render, it just places random sections of the screen into that window. This makes me sad since the glide wrapper allowed me to double the screen resolution to play in a 1600x1200 window (the game itself only runs at 800x600). 

System specs: linux kernel (Fedora stock). NVIDIA Quadro FX 3800, tried driver versions 256.35 and 260.19.21. I've tried with Composite in xorg enabled and disabled. 

Any ideas?

More information about the wine-users mailing list