[Wine] Problem building 1.3.8 from source

PleegWat pleegwat at telfort.nl
Sat Nov 27 05:52:03 CST 2010


I've been building wine from source for years, originally because I 
needed some custom patches, nowadays out of habit. Just now I'm trying 
to build 1.3.8, but I get an error during build:

make[1]: Entering directory `/home/peter/src/wine/dlls/atl'
gcc -m32 -c -I. -I. -I../../include -I../../include  -D__WINESRC__ 
-D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing 
-Wdeclaration-after-statement -Wstrict-prototypes -Wtype-limits 
-Wwrite-strings -Wpointer-arith  -g -O2 -U_FORTIFY_SOURCE 
-D_FORTIFY_SOURCE=0  -o registrar.o registrar.c
registrar.c: In function ‘DllGetClassObject’:
registrar.c:778: error: ‘CLSID_Registrar’ undeclared (first use in this 
registrar.c:778: error: (Each undeclared identifier is reported only once
registrar.c:778: error: for each function it appears in.)
registrar.c: In function ‘do_register_server’:
registrar.c:827: error: ‘CLSID_Registrar’ undeclared (first use in this 
make[1]: *** [registrar.o] Error 1
make[1]: Leaving directory `/home/peter/src/wine/dlls/atl'
make: *** [dlls/atl] Error 2

I've tried rerunning configure, ran into missing gstreamer libs, 
installed those from synaptic. Now configure runs without complaints, 
but I still get this error.

Thanks in advance,


More information about the wine-users mailing list