[Wine] Firmware update via USB to Sony NEX camera

linuxvinh wineforum-user at winehq.org
Thu Oct 7 18:47:36 CDT 2010


I would like to update my newly acquired Sony NEX camera's firmware.  The supplied firmware is packaged in a .exe that's listed on Sony's site as compatible with Windows 2000, XP, Vista and 7.  I ran the .exe under WINE, which was set to XP.  The program executes and opens its dialog.  The first thing it does is try to find the camera, connected via USB, and determine the current firmware version.  Unfortunately, it is unable to find the camera.

1. switch camera to Mass Storage mode
2. plug camera into USB 2.0 port
3. mount camera as /media/disk
4. execute WINE with .exe
5. tell .exe to start the firmware update

6. camera not found

I've tried WINE 1.1.28, 1.3.3 and eventually 1.3.4 with a USB patch I found at this location:


I did a "wineconsole cmd" and D: did work properly to access the camera as a mass storage device, when D: was assigned as /media/disk.

Any suggestions on what I might try next?  Any debugging switches I can toggle on to provide more info on what is happen?


P.S.  I have a similar thread on openSUSE forums, but the thread has run it's course, with the conclusion being to install Windows to avoid the hassle.  I'm not ready to give up yet!

More information about the wine-users mailing list