[Wine] Wine and WoW Cataclysm Patch 4.0 troubleshooting thread

PleegWat pleegwat at telfort.nl
Wed Oct 13 13:31:12 CDT 2010

On 10/13/2010 02:40 AM, mw13068 wrote:
> Hello,
> The WoW 4.0 Cataclysm patch landed today, and there's bound to be lots of questions about getting it running in wine.
> My current status is that I've downloaded the patch and installed it.  I've got the new (original WoW) login screen graphic.  Once I login, I see a new character background and then a "downloading update" message.  Wine crashes moments later.
> I'll try what I can think of to resolve this and report back.


My system: Wine 1.3.4, ubuntu 10.04. Nvidia binary drivers from ubuntu 
proprietary drivers screen (version 195.36.24). WoW patched itself 
without problems.

I'm unable to get it working properly though: In WinXP mode, both openGL 
and direct3d, I get this error:

err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 

When launching WoW with wine set to Vista or Win7 mode, it starts 
properly, however I do not get any sound. The following set of messages 
shows on my screen 5 times:

err:ole:COMPOBJ_DllList_Add couldn't load in-process dll L"mmdevapi.dll"
err:ole:create_server class {bcde0395-e52f-467c-8e3d-c4579291692e} not 
fixme:ole:CoGetClassObject CLSCTX_REMOTE_SERVER not supported
err:ole:CoGetClassObject no class object 
{bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x17

Combining with wow's sound log, I deduce that mmdevapi.dll is the only 
sound API it is trying, and I've had that disabled for a while because 
sound with it does not work. Re-enabling mmdevapi, I get some weird 
noise for a fraction of a second during game start, and then a seemingly 
infinite series of copies of the following message:

err:mmdevapi:ACR_ReleaseBuffer Starting from 1014

Also, it seems most video settings are not available in openGL mode. 
Setting it to Direct3D allows most settings in the detail boxes, but 
only up to 'fair' in the main slider, and most settings under 'liquid 
detail' and 'sunshafts' stay disabled with the message 'Unsupported for 
graphics related reasons'.

Does anyone have any ideas? I'd particularly like to get my sound 
working - I rely on audio cues for ability timing, so I'm worthless 
without sound.


More information about the wine-users mailing list