[Wine] Running vbscript .vbs file in an EXE

Afam Agbodike agbodike at gmail.com
Wed Sep 1 02:07:17 CDT 2010

Hi, I'm new to wine, and am having a bit of trouble.

I'm trying to run an EXE installer, which starts fine, prompts me for
a few questions, and creates a few directories, but at a certain point
it tries to run a vbs file, which fails.

The attempt to run the .vbs file causes this message to appear in an
alert window:

"There is no Windows program configured to open this type of file"

after which I click OK and there as another window:

"could not execute the external program check64.vbs"

with "check64.vbs" being the name of the file that is part of the installer.
after I click OK the installer exits, and there is no output at the
command line whatsoever:

bash-3.2$ wine ~/Desktop/INSTALL.EXE

I've used winetricks to install

vcrun6 (which I believe is the same as mfc42, but I thought I try and
see if it fixed the problem, with no luck)

I'm not sure if this is sufficient to run vbs files.

I have tried:

bash-3.2$ wine wscript test.vbs

which seems to partially work, but I get the error message
there is no script engine for file extension ".vbs"

and my test script doesn't do what I expect, the attempt causes this
to be printed on command line:

fixme:ole:CoInitializeSecurity (0x0,-1,0x0,0x0,0,3,0x0,0,0x0) - stub!

I believe it's a wise installer, and that it's pretty old, so I tried
running it as Windows 95 & 3.1 with no more success. I'm guessing I
need to add some entries into the registry, but as I haven't used
windows in quite a while, and never messed around with the registry
much, any suggestions would be greatly appreciated.

I'm running:

bash-3.2$ wine --version

Installed via MacPorts on Snow Leopard

More information about the wine-users mailing list