[Wine] [Fwd: Re: Trouble with libgsm on Mac OS X 10.6.2]

James McKenzie jjmckenzie51 at earthlink.net
Mon Sep 6 21:01:05 CDT 2010

James McKenzie wrote:

> rwoodsmall wrote:
>> James McKenzie wrote:
>>> doh123 wrote:
>>>> I'm not sure LD_LIBRARY_PATH actually does anything on OSX...
>>>> there are a lot of related things you can do though... just look at 
>>>> 'man dyld'
>>> Doh123:
>>> Yes it does.  Look it up for FreeBSD.
>> James:
>> No it doesn't.  Like doh123 said run 'man dyld.'  Mac OS X/Darwin 
>> uses it's own C library and kernel, with bits of Free/Net/OpenBSD 
>> mixed in.  But more importantly to this discussion, it uses its own 
>> dynamic linker - dyld.  LD_LIBRARY_PATH doesn't do anything on OS X.  
>> Saying it does doesn't make it so.  The equivalent environment vars 
>> look at the dyld man page would have told you that.
>> Grow a clue and stop giving advice until you do.  It's getting old.
> I'm pulling this from another source.  Thank you for the correction.  
> I'll give the source a pointer in the right direction.  I guess I'm 
> mixing Solaris/RedHat and Macs again...(Apples and whatever.)
> Interestingly enough, LD_LIBRARY_PATH seems to work on my Mac.  I'll 
> fix that though.
Now, here is something completely different:

Build Wine using scripts to build dependencies and place them in 
$BUILDDIRECTORY/usr/bin...lib....etc...so on and so forth.

Run any of the tests (riched20, gdi32, etc.) WITHOUT setting the 

and I get the following:

err:module:load_builtin_dll failed to load .so lib for builtin 
258): Symbol not found: __cg_jpeg_resync_to_restart
 Referenced from: 
err:module:import_dll Loading library gdi32.dll (which is needed by 
failed (error c000007a).
err:module:LdrInitializeThunk Main exe initialization for 
failed, status c0000135

repeated for pages and pages.

Run the tests BUT use LD_LIBRARY_PATH:

All is well, no errors except test errors.

Interesting, eh?

This is why I made the statement earlier about using LD_LIBRARY_PATH.  I 
know that I'm not the only one to suffer with this.  Any idea why this 
does not work?

If necessary, we can move this to the development mailing list and away 
from here.

I agree, this SHOULD WORK with the DYLD and not the LD given what I read 
from the man page(s).

And yet even more:

If I don't set any LIBRARY_PATH, I get fontconfig errors and more tests fail.

As I stated, strange as the executables are mach-o 32 bit (I don't build 64 bit, yet) and the libraries are mach-o (dylib), not .so files.

James McKenzie

More information about the wine-users mailing list