[Wine] Problem installing from source, 1.3.2 "..prelink not found"

RaistlinM531 wineforum-user at winehq.org
Sun Sep 12 12:28:47 CDT 2010

Hi all! 

Trying to get magic workstation (www.magicworkstation.com) to run correctly. My distro (BT4R1) comes with an older version of wine, so I uninstalled it then installed Wine Stable 1.2. Compiled it manually, got it everything it needed save one thing from the ./configure and it seemed to install fine, but it did not fix my problem. There are still some game breaking graphical isssues with it. Ok, so I decided I would try the latest version, since the latest stable didn't work. Uninstalled previous version. Downloaded 1.3.2.  When I run   'make ./configure' I get two errors at the end:

configure: libmpg123 development files not found (or too old), mp3 codec won't be supported.

configure: WARNING: prelink not found, base address of core dlls won't be set correctly.

I am worried about the second one, obviously. The first one was the one thing with the 1.2 install I could never get to work, but it installed fine w/o it. This second one seems to be a bigger deal. I went ahead and ran 'make depend.' Seemed to work, but when I run just 'make' this is what it gives me:

root at bt:/bin/wine-1.3.2# make
make[1]: Entering directory `/bin/wine-1.3.2/tools'
make[1]: `makedep' is up to date.
make[1]: Leaving directory `/bin/wine-1.3.2/tools'
make[1]: Entering directory `/bin/wine-1.3.2/libs/port'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/bin/wine-1.3.2/libs/port'
make[1]: Entering directory `/bin/wine-1.3.2/libs/wine'
gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__ -DWINE_UNICODE_API="" -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wstrict-prototypes -Wtype-limits -Wwrite-strings -Wpointer-arith -Wno-unused-result  -g -O2  -o debug.o debug.c
debug.c: In function 'debug_usage':
debug.c:180: warning: ignoring return value of 'write', declared with attribute warn_unused_result
At top level:
cc1: error: unrecognized command line option "-Wno-unused-result"
make[1]: *** [debug.o] Error 1
make[1]: Leaving directory `/bin/wine-1.3.2/libs/wine'
make: *** [libs/wine] Error 2

Not sure if 'this' problem is related to the problem I saw in ./configure, but I wouldn't bet against it, especially since a previous version seemed to install fine. 
Any help would be appreciated, thanks!

More information about the wine-users mailing list