[Wine] Re: Problem installing from source, 1.3.2 "..prelink not f

RaistlinM531 wineforum-user at winehq.org
Mon Sep 13 07:07:50 CDT 2010

Hi all, thanks for the help thus far.

So I installed prelink which does take care of the ./configure error. I only have the one other error in the config now, which I am fairly sure is not a part of the 'make' problem since I was able to compile 1.2 with the same error. After fixing the prelink, i run make depend again and again make, and come back with the same error:

/bin/wine-1.3.2# make
make[1]: Entering directory `/bin/wine-1.3.2/tools'
make[1]: `makedep' is up to date.
make[1]: Leaving directory `/bin/wine-1.3.2/tools'
make[1]: Entering directory `/bin/wine-1.3.2/libs/port'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/bin/wine-1.3.2/libs/port'
make[1]: Entering directory `/bin/wine-1.3.2/libs/wine'
gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__ -DWINE_UNICODE_API="" -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wstrict-prototypes -Wtype-limits -Wwrite-strings -Wpointer-arith -Wno-unused-result  -g -O2  -o debug.o debug.c
debug.c: In function 'debug_usage':
debug.c:180: warning: ignoring return value of 'write', declared with attribute warn_unused_result
At top level:
cc1: error: unrecognized command line option "-Wno-unused-result"
make[1]: *** [debug.o] Error 1
make[1]: Leaving directory `/bin/wine-1.3.2/libs/wine'
make: *** [libs/wine] Error 2

I did check the app database and did see that it is apparently working better with version 1.1.42. I did know there was a previous version that it did work with (via a mws forum) but didn't know the version number. I just kinda figured the latest stable one would do the trick. I might be interested in running other things in WINE besides this in the long term, (world of warcraft if it is possible) so I would like the most up to date version that runs this thing, but obviously the next thing I will try is this previous version. While I do that today, if anyone has any idea about the error above, I'd love to hear it! Thanks!

More information about the wine-users mailing list