[Wine] Re: No sound, no information why, where to start?

atle wineforum-user at winehq.org
Tue Sep 14 02:03:27 CDT 2010

>Ya, I don't use KDE, i just naturally assume it plays a similar role 
to Pulseaudio (which also can set sound). 

Sorry, bad description on my part. kmix is an alsamixer equivalent for KDE. It doesn't play anything, or mix sound streams like dmix.

>That's kind of what i would expect to see. 

I wouldn't. Where is gstreamer finding a default ALSA device that aplay can't find?

This is linked to the previous question, why can't aplay -L or KDE4/phonon/gstreamer find the devices I create in asound.conf?

I wish there would be some more consistency here.

>Have you tried a fresh install of Wine??? you can do this simply by 
renaming your .wine folder (as to not lose anything), then try 
uninstalling Wine.

I'll try that. I have only tried removing .wine to recreate settings.

>For you to not have changed anything, and 
it just stopped working.

I didn't say that. I upgrade gentoo all the time. I even upgrade kernel now and then. Also I've changed from a ATI47** to an ATI56**. But these are steps that cannot easily be reversed.

Also, sound is working. It's just wine doing something strange. But I'll try reinstalling it tonight.

What I miss is something like what was used in the old ~/.wine/config:
"PlaybackDevice" = "default" 

(Ref: http://wiki.jswindle.com/index.php/Wine_Config_File)

If I found a way to do the same in the new .reg files, I'd be happy.

More information about the wine-users mailing list