[Wine] General Alawar games issue

OpalDragon wineforum-user at winehq.org
Tue Sep 21 08:12:23 CDT 2010

See bug 23374.  Originally, this was an issue raised for one particular game.   But my experiences with other games from the same company indicate that this may be a more widespread problem for their games.

The original poster tried one of their "Strange Cases" games.  I've tried a "Natalie Brooks" and an "Alabama Smith" adventure.  Each keeps coming up with the same issue.  As originally posted in the bug, the program returns these errors when run from a command line:

fixme:mountmgr:harddisk_ioctl unsupported ioctl 4d004
fixme:mountmgr:harddisk_ioctl unsupported ioctl 4d004
err:seh:setup_exception_record stack overflow 1620 bytes in thread 0009 eip
7bc3f253 esp 00230cdc stack 0x230000-0x231000-0x330000

At that point, execution stops.  Now some of the specifics can change from game to game, system to system, perhaps even one execution to the next, but the general layout of the issue is as shown.  The harddisk_ioctl issue I've seen in various incarnations in several other posts, but have not seen any resolution.

Does anyone have ideas for what to do to fix these issues?

More information about the wine-users mailing list