[Wine] Junk appended to filepath, impossible to read from filesystm

savalas wineforum-user at winehq.org
Thu Sep 23 13:07:32 CDT 2010

FYI this topic was crossposted to Gentoo forums (http://forums.gentoo.org/viewtopic-t-845865.html)


Yesterday I updated Wine from 1.3.2 to 1.3.3 and today when I wanted to use a program through Wine (a text editor, but it doesn't really matter) I received an error that some files could not be found. The filepath given in the error message was wrong, instead of reading something like /home/user/.wine/foo/bar it was /home /user /.wine /foo /bar  (this is not the actual path as I couldn't select the error message.) Using the file selector, I could find that filenames contained some junk at the end. After further inspection, I found that 3 bytes are appended to each filename and those bytes correspond to the type of entry, specifically: 
[list][*]e1a080 - file 
[*]e18880 - dir 
[*]e19080 - mount point

Now I'm kind of stuck because I have no idea on how to solve that problem. I have tried to downgrade to Wine 1.3.2 but now the same problem occurs. I have tried to wipe my .wine dir and start anew, without success. I have to assume that the problem is not in Wine 1.3.3 but rather in some dependency that got upgraded between the first time I compiled Wine 1.3.2 and yesterday when I compiled 1.3.3.

I'm on Gentoo ~amd64, I'm using the emul-linux-x86-*-20100915 packages and downgrading to emul-linux-x86-*-20100611 didn't fix it. I guess that I need to find what library or subsystem is responsible for translating Windows filepaths (e.g. C:\foo\bar) to Linux's (e.g. /home/user/.wine/drive_c/foo/bar) and investigate that.

Any help would be appreciated.

More information about the wine-users mailing list