[Wine] Team Fortress 2 Bug Fix Undone by New Patch

Entanglement wineforum-user at winehq.org
Mon Aug 15 17:59:51 CDT 2011

Okay, so awhile back I had a problem with Steam. It wouldn't start and so I fixed that after installing a minimal version of winetricks (I removed a few things I knew I wouldn't need). Then Steam worked.

Unfortunately I then had a problem with Team Fortress 2. This time the game wouldn't load. So I read the AppDB for Team Fortress 2 again and it said to disable Steam Community In-Game, I did and it worked.

This new problem I need help with is similar and exactly like the problem in the second paragraph. Team Fortress 2 won't start. Take in mind that I did already have Steam In-Game Community disabled and double checked it before making this post.

Basically what happens is I will launch Team Fortress 2 and it immediately crashes after Steam activates it, and by this I mean it gives the message "Preparing to start Team Fortress 2..." or something around those lines. So I decided to start it from Steam. Steam worked fine, I could open Libraries and all of that. When I started it from Steam, I would get the message "Loading..." (in the bottom right hand corner) with the white picture of a game map (the standard loading screen) so I thought it was going to be successful. Trying Team Fortress 2 again normally (not going into Steam first), it acts in the same manner of me going into Steam directly instead of crashing right after the black box with "Preparing to start Team Fortress 2..."

Normally the loading screen takes like 30 seconds to finish, but this time it stayed on the loading screen for about 10 seconds, and then crashes again.

As paragraph 2 describes, it's the similar error as when I had "Steam In-Game Community" enabled and it even gives the same error message:

> preloader: Warning: failed to reserve range 00010000-00110000

Is anybody else getting the same, or similar problem with the newest update to Team Fortress 2?

More information about the wine-users mailing list