[Wine] 2 mouse cursors visible using a steam app

Maquis196 wineforum-user at winehq.org
Fri Aug 19 17:03:31 CDT 2011

All, I am finally stumped enough by something to post in the forum! Basically whilst running a game through steam (either from steam itself or running the exe directly) I get 2 cursors. Now one of them is the one I would expect and works properly, however the second one is kinda anchored to the middle of the screen and looks like the gnome cursor.

If you move your mouse, the middle cursor tries to move in same direction but snaps back to the middle. Now some tested games;

CS:S - During menu the middle cursor isn't there, but as soon as you enter game it's under the crosshair
Splinter Cell (original) - original problem
Elder Scrolls oblivion - same

It only appears to affect my steam prefixes, I've tried a steam install with no overrides and same problem, yet another game in a different prefix (like bridge commander) hasn't got the same problem. In fact im sure its steam related. It happens in xfce4 as well so I'm reluctant to blame gnome. 

Anyone got any ideas? I'm truely out of ideas :S (yes I have tried all the window settings in winecfg, no difference!)

Oh and hello all, I'm the super for a few old games so thought I'd say hi as well!

Using Gentoo with wine 1.3.26


More information about the wine-users mailing list