[Wine] Apps segfaulting, problem with X?

tradet wineforum-user at winehq.org
Sat Aug 20 15:37:25 CDT 2011


I'm having big trouble getting wine to work.

What I basically want to do is get steam to work, now it even fails to launch at all. It updates to 99% and then it segfaults. Other games has done this too (rollercoaster tycoon 2, starcraft 2). I followed the instructions on winehq, removed oriya/samyak fonts and I don't think I've done anything wrong - I've installed steam before on other computers.

$ wine Steam.exe
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
err:seh:setup_exception_record stack overflow 836 bytes in thread 0009 eip 7ef86e2d esp 00230fec stack 0x230000-0x231000-0x330000
zsh: segmentation fault  wine Steam.exe

I'm running Slackware 64 with multilib and I've tried to compile wine as both a 32bit and 64bit app, using the prebuilt slackware packages all using version 1.3.26 and 1.2.3.

I've got 2 monitors and I've tried using a dual screen xinerama layout and a layout with just a single screen. I'm happy to have two xorg.conf and I can just switch to one when I want to play if it comes to that, so for now I'm just ignoring the xinerama setup.

xorg.conf (single screen):

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "InputClass"
    Identifier     "Keyboard Defaults"
    MatchIsKeyboard "yes"
    Option         "XkbLayout" "se"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2211H"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 550 Ti"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: 1920x1080 +0+0"
    SubSection     "Display"
        Depth       24

Output with a single screen:

$ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 175, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      50.0*
   1400x1050      51.0     52.0
   1280x1024      53.0     54.0     55.0
   1280x960       56.0     57.0
   1152x864       58.0
   1024x768       59.0     60.0     61.0     62.0     63.0     64.0
   960x720        65.0     66.0
   928x696        67.0     68.0
   896x672        69.0     70.0
   832x624        71.0
   800x600        72.0     73.0     74.0     75.0     76.0     77.0     78.0     79.0     80.0     81.0
   720x400        82.0
   700x525        83.0     84.0
   640x512        85.0     86.0     87.0
   640x480        88.0     89.0     90.0     91.0     92.0     93.0     94.0
   640x400        95.0
   640x350        96.0
   576x432        97.0
   512x384        98.0     99.0    100.0    101.0    102.0
   416x312       103.0
   400x300       104.0    105.0    106.0    107.0    108.0
   360x200       109.0
   320x240       110.0    111.0    112.0    113.0
   320x200       114.0
   320x175       115.0

xrandr doesn't work with xinerama enabled.

I'm using the propriatery nvidia driver (280.13) with my graphics card GTX 550Ti.

glxgears works but exits with the error:

$ glxgears
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 49 requests (49 known processed) with 0 events remaining.

This is a problem I've seen in other apps as well, though I can't recall which atm.

winecfg and notepad works as well.
I've tried setting a virtual desktop in winecfg. I've spent a lot of time googling for an answer but I can't even find a recent post who fails to get steam to even launch, so I think it must be a problem with my X setup.

I installed Virtualbox and tried to use that for gaming but it was unsatisfactory, games were slow and buggy and some even failed to launch (X setup/virtualbox setup?).

I've run slackware in a similar setup before on my laptop without having these problems (Steam and gaming worked on a 64bit slackware). I even tried to copy the whole .wine directory but with no avail.

Any tips and ideas are very much welcome!

Thanks in advance,


More information about the wine-users mailing list