[Wine] X server Display error in Debian Linux with KDE

perryh at pluto.rain.com perryh at pluto.rain.com
Thu Jul 7 10:52:36 CDT 2011

Gary Roach <gary719_list1 at verizon.net> wrote:

> I am getting the following when I run winecfg or wine control in
> my command line console. The X server is definitely running since 
> everything in KDE works fine. Running echo $DISPLAY returns :0
> No protocol specified
> No protocol specified
> Application tried to create a window, but no driver could be loaded.
> Make sure that your X server is running and that $DISPLAY is set
> correctly.
> What is $display supposed to return.

$display (lower case) will normally be unset.  $DISPLAY (upper case)
will normally be set to :0 or :0.0 in the (typical) situation where
the "client" (application, wine in this case) and the "server"
(display handler, usually xorg these days) are running on the same

> Any suggestions for how to clear this problem.

What happens if you try to run a "simple" X application (such as
xterm or xclock) in the same console where Wine is failing?  If
that produces the same result, you have a problem with X that has
nothing to do with wine; maybe your distro's support forum can

You aren't by any chance trying to run wine as root?  That is very
seldom a good idea.

More information about the wine-users mailing list