[Wine] Re: Wine 1.3.24 and Age of Conan: Anybody made it work?

ischou wineforum-user at winehq.org
Thu Jul 21 22:35:56 CDT 2011

On Mac OS X 10.6.8 the installer does not work.  I let the installer run to completion using Windows XP in a VM and setting the install directory to install into my WINEPREFIX/drive_c/Program Files/Funcom/Age of Conan

When the installer runs to completion, I shut down the VM, and attempted to run AgeOfConan.exe.  I'm sure the Installer/Patcher does not work correctly in Wine on Mac OS X because this time the Patcher did not detect the installation to be corrupt (as it had before).

The AgeOfConan.exe automatically starts up the ConanPatcher.exe which does not update unless I drag other X windows over it.  All the widgets on the ConanPatcher.exe work, and I was able to select settings by "manually updating" the window by dragging other windows over it.

When I clicked "Start" I was presented with an EULA, which I clicked "Accept" and then the program crashed.

Here are excerpts of the error messages:

[2011-07-22 02:58:30Z #0] [ID:0] ERROR: Main - Invalid clienthash arg 
[2011-07-22 02:58:30Z #0] [ID:0] ERROR: Main - Invalid patcher key arg

[2011-07-22 03:00:36Z #0] [ID:0] [fcCore/IOBuffer] Decompress(): Could not decompress stream. src-size:117219 dst-size:174800 zlib-error:-3
[2011-07-22 03:00:36Z #0] [ID:0] [ResourceManager] Resource 1010004:200575 does not have correct md5 (76cd80ca0d165b16f2442928fcc7b52d!=744b8f8c6537fc19af3dcebc906bfe38)

There are several of those zlib errors and incorrect md5s errors.

fixme:wave:AudioUnit_SetVolume independent left/right volume not implemented (1.000000, 1.000000)
err:ntdll:RtlpWaitForCriticalSection section 0x39284e4 "?" wait timed out in thread 0023, blocked by 0028, retrying (60 sec)
Thu Jul 21 20:01:37 ivanstibook wine[40787] <Error>: kCGErrorIllegalArgument: CGSGetSurfaceBounds
Thu Jul 21 20:01:37 ivanstibook wine[40787] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
Thu Jul 21 20:01:37 ivanstibook wine[40787] <Error>: unknown error code: invalid drawable
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented

[2011-07-22 03:01:44Z #0] [ID:0] ERROR: ResourceManager - RDBSource_c::ProcessRequest. Resource 1010513:150119 does not exist in any available RDB sources.

There are quite a few of the above errors too.

fixme:wbemprox:wbem_locator_ConnectServer 0x15ab0308, L"\\\\.\\root\\cimv2", (null), (null), (null), 0x00000000, (null), 0x0, 0xd71f62c)
fixme:win:EnumDisplayDevicesW ((null),0,0x33e90c,0x00000000), stub!
fixme:d3d:debug_d3dformat Unrecognized 0x34324644 (as fourcc: DF24) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x34324644) in the format lookup table

Strange that I'm still getting this error.  I installed d3dx9_36.

err:d3d:resource_init Out of adapter memory
fixme:d3d_texture:texture_init Failed to create surface 0x15ce3050, hr 0x8876017c

I get lots and lots of the above error.

fixme:d3d:debug_d3dformat Unrecognized 0x31495441 (as fourcc: ATI1) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x31495441) in the format lookup table
fixme:d3d9:Direct3DShaderValidatorCreate9 stub
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  128 (Apple-DRI)
  Minor opcode of failed request:  2 ()
  Value in failed request:  0x1800004
  Serial number of failed request:  363
  Current serial number in output stream:  363
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
[2011-07-22 03:02:05Z #0] [ID:0] ERROR: XMLObject - XMLDataContainer::GetAttrRect() failed to parse 'Rect(10,0,5,COORD_MAX)' as a Rect.
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0x17fbf640): stub
fixme:faultrep:ReportFault 0x17fbf0a4 0x0 stub

And then finally AoC crashes.  Upon trying to run AoC a second time (this time I tried winetricks orm=backbuffer to see if that would help the ConanPatcher.exe draw/refresh properly) the ConanPatcher.exe screen was flipped vertically (text backwards) and this time I received the "your installation is corrupt" which implies that the last time I tried to run AoC, the patcher got the wrong MD5 hash and "updated" my installation, thus breaking it again.

The next time I have a spare 5 hours, I'll try reinstalling and then immediately prevent the patcher from running and corrupting my installation.

More information about the wine-users mailing list