[Wine] Wine does not allow program to see USB ID

pluMmet wineforum-user at winehq.org
Fri Mar 4 07:35:37 CST 2011

I have a program called Messiah Studio. It licenses to your USB drive. Some people over on their forum have gotten it working under Wine but they go thru so many steps to do it that by the time they are done they are not sure which steps did the trick. So far all we have diduced is that you need Wine 1.3 and you need the drive mounted as low a level as possible.

Here is what I have so far.

I typed all these things into the terminal to make sure to erase the programs and libraries in Wine

rm -rf $HOME/.wine

rm -f $HOME/.config/menus/applications-merged/wine*

rm -rf $HOME/.local/share/applications/wine

rm -f $HOME/.local/share/desktop-directories/wine*

rm -f $HOME/.local/share/icons/?Huh_*.{xpm,png}

rm -f $HOME/.local/share/icons/*-x-wine-*.{xpm,png}

Then I erased my Wine install which was a little difficult because you have to uninstall by the same method you use to install it.

Then I had to install the newest one and I used this:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get build-dep wine1.3

which worked great.

I disabled automount:

open a terminal and type gconf-editor.

Browse to /apps/nautilus/preferences/media_automount change it to off.

I Installed thunar with the code:

sudo apt-get install thunar

Then I safely removed the USB and reinserted the USB but it did not mount so in terminal I typed sudo thunar which brought up an explorer and I selected the USB and it mounted as root.


So that's what I have so far. Still not working. Help me  [Exclamation]

More information about the wine-users mailing list