[Wine] Page fault issue, need help

Vilem Otte wineforum-user at winehq.org
Sat Mar 5 16:33:56 CST 2011


I've just installed Wine 1.3.14, it is good and I really like it - some games are running okay (F.e.HOMAMs), although I met some issue in another (recently TES 4: Oblivion, Fallout 3).

On 1.3.13 everything worked, then I reinstalled to 1.3.14 (which I think didn't have any impact on it), but did few steps from Fallout 3 guide (e.g. how to get it working), and Fallout 3 is not still working.

As a matter of fact, my Oblivion also got corrupted, I can start new game in prison, play a bit, and as soon as I get to place, where you're first attacked (and one of the blades killed) the game crashes with:


wine: Unhandled page fault on read access to 0x00000014 at address 0x7a6a8a4e (thread 0009), starting debugger...

I haven't tried anything (as I got it in 1.3.13 running out of the box without any issues), except patching Oblivion to 1.2. No effect - still same issue, after a while it crashes at 0x7a6a8a4e

In Fallout3 the same crash (page fault on read access to 0x00000014 at 0x7a6a8a4e (thread 0009 or thread 0029 written right after it)) kills the game right after intro video (e.g. when engine should start - when you're born).

Can anyone please guide me through - I'm quite new to using Wine, so a bit desparate.

More information about the wine-users mailing list