[Wine] "cmd.exe /c echo '%ProgramFiles%' returned empty string"

dE_logics wineforum-user at winehq.org
Thu Nov 10 04:16:08 CST 2011


I'm trying to install a program using winetricks, but I'm using a separate wine install and WINEPREFIX, I run any command as such - 

WINEARCH="win32" WINE='/home/de/media_writeit!/FOSS/additional packages/Wine prefixes/Works with wine 1.3.32/wine-1.3.32' WINEPREFIX='/home/de/media_writeit!/temp(others)/walkthrough' ./winetricks

And it returns - 

/home/de/media_writeit!/FOSS/additional packages/Wine prefixes/Works with wine 1.3.32/wine-1.3.32 cmd.exe /c echo '%ProgramFiles%' returned empty string

Also in the winetricks wiki it has not been explained properly how to point out to a seperate wine install.

I tried exporting all the WINE, WINEPREFIX and WINEARCH variables, but it doesn't workout.

On the other hand - 

WINEPREFIX='/home/de/media_writeit!/temp(others)/walkthrough' '/home/de/media_writeit!/FOSS/additional packages/Wine prefixes/Works with wine 1.3.32/wine-1.3.32/bin/wine' cmd

C:\>echo %ProgramFiles%
C:\Program Files


More information about the wine-users mailing list