[Wine] help with midi

raybert wineforum-user at winehq.org
Wed Nov 23 23:51:44 CST 2011


I'm trying to update the firmware of a musical device using a proprietary windows app that wants to write to a midi port (the device is a TC Electronics Nova System).

I have an M-Audio Uno USB MIDI interface on my Fedora 15 laptop and it is working correctly (I can successfully capture SysEx dumps using amidi, etc.).

The output of `amidi -l` is:

> Dir Device    Name
> IO  hw:1,0,0  USB Uno MIDI Interface MIDI 1

The output of `aconnect -o` is:

> client 14: 'Midi Through' [type=kernel]
>     0 'Midi Through Port-0'
> client 20: 'USB Uno MIDI Interface' [type=kernel]
>     0 'USB Uno MIDI Interface MIDI 1'

Winecfg (version 1.3.24) shows the device in the Audio tab on the ALSA Driver branch.  There is also a PulseAudio Driver branch and I have enabled only ALSA (according to the FAQs).

When I run the updater SW it indicates that there are no MIDI ports.

I installed the MIDIOX app to help diagnose this.  When I run it a dialog appears saying there are no MIDI devices.

Since the MIDI Through device shows up first in the list, I tried setting the HKCU\Software\Microsoft\Windows\CurrentVersion\Multimedia\MIDIMap\CurrentInstrument registry key (as described @ http://wiki.winehq.org/MIDI) but this did not help.  I've tried using both "#1" and the device name ("USB Uno MIDI Interface MIDI 1") but no difference.

I'm not sure what to try next.  If anyone has any ideas I'd really appreciate the help.



More information about the wine-users mailing list