[Wine] Re: Solar Accounts

nadrach wineforum-user at winehq.org
Sun Oct 23 10:57:14 CDT 2011

Solar Accounts has been running for some time on Kubuntu netbook 10.04.1 on the the eeePC, using jre6_24 masquerading as 1.5.0_08 ... i.e SA looks in its own local directory called jre1.5.0_08 for Java, but what is in there is a copy of jre1.6.0_24. This worked (mostly) fine until wine 1.3.30. The only glitch was an occasional failure-to-start citing an inability to initialise the Java virtual machine.

This continued with a fresh install of Kubuntu 10.04.1 on an Acer Aspire One D255E, currently being prepared as a replacement for the eeePC.

However ... on the upgrade to wine 1.3.31, today, the inability to start the VM became permanent.

I tried installing the latest Java (1.6.0_25), but this reported an install glitch ...

An error has occurred while processing the shared archive file.
Unable to create shared archive file C:\Program Files\Java\jre6\bin\client\classes.jsa.
Error occurred during initialization of VM

... now this file has read-only permissions, but it turns out to be installed that way ... so not a file permissions fault. However, checking all the file info in the various Java installations showed only one oddball ...

C:\Program Files\Java\jre6\lib\servicetag\registrations.xml

... which had a mix of jre6_24 and jre6_25 data in it, probably because I had installed 25 over 24.

So I did a clean install of jre1.6.0_25, with no reports of VM problems, then copied that to the local SA Java directory, replacing the earlier <used> jre1.6.0_24. Bingo ... Solar Accounts starts ... for how long I have yet to confirm ... but so far, so good.

The questions I have are ...

(1) Does Java always have to be installed clean on wine, not by upgrade?

(2) Since the VM lockout occurred after I upgraded wine from 1.3.30 to 1.3.31, does this mean I have to recopy a fresh Java across to Solar Accounts every time I get a Wine update in future?

More information about the wine-users mailing list