[Wine] WineASIO JACK possible regression, Wine 1.3.26 ?

jordan triplesquarednine at gmail.com
Fri Sep 2 19:40:04 CDT 2011


> the Generic Kernel + Wine 1.3.26 has problems with WineASIO JACK.
> if i could re-install 1.3.15 to test if its Wine1.3.26 or something else.

I use wine-rt (1.3.26) with WineASIO - there isn't any regression, as
far as i know, and i am using wineASIO on a daily basis. (and have
been for a long time... years).

1. you say the generic kernel has problems with wineASIO and Jack.
please explain. do you mean it doesn't work, or do you mean you get
lots of xruns? (which would be half expected from a generic kernel).

2. has WineASIO worked properly in the past on your machine, on this install?

> Removed & Installed Wineasio...

3. I went and looked at the .deb of wineASIO for kxstudio,
re-installing it wouldn't do anything. All that package does is
install /usr/lib/wine/wineasio.dll.so . I'm not even sure if it
registers wineASIO for you.

4. Have you registered wineASIO in the wine registry?

type from commandline:

regsvr32 /usr/lib/wine/wineasio.dll.so (type as normal user, not root!)

5. is wineASIO available as a driver in your wine applications?

6. what happens when you try to use it? (as in launch your wine app,
from the commandline)

> removed the KDE non free meta...
> re-installing Wineasio did not re-installed KDE non-free meta .
> re installing kxstudio non-free meta 3.1, didn`t solved the WineASIO...

I'm not sure what these packages install, but typically, one only
needs Wine, wineASIO and Jack installed, nothing else should affect
whether wineASIO works or not.


More information about the wine-users mailing list