[Wine] Wine dump/Mass Effect 2

MacNean Tyrrell dardack at gmail.com
Sat Sep 3 22:38:41 CDT 2011

So I'm posting this here, so someone else doesn't pull their hair out.  Not
sure what setting in my ~/Bioware/Mass Effect 2/.. got F'd the F'd up.  But
sitting here thinking, you know it worked 14 hours ago, it worked for long
time.  Fresh install on everything doesn't change anything, except I kept my
home folder (so I don't loose stuff).  Hmmm remove Bioware/ME2 folder, now
I'm in again.  So try that if all else fails.

On Sat, Sep 3, 2011 at 11:33 PM, MacNean Tyrrell <dardack at gmail.com> wrote:

> Full OS reinstall (complete reformat of my OS partition).  Still same
> error.  Seems if vcrun2005 is run with winetricks I get:
> Backtrace:
> =>0 0x78145178 in msvcr80 (+0x15178) (0x0194ea20)
>   1 0x00681546 in masseffect2 (+0x281545) (0x0194eb20)
>   2 0x00baa651 in masseffect2 (+0x7aa650) (0x0194ebf4)
>   3 0x00be16db in masseffect2 (+0x7e16da) (0x0194f070)
> If I set mscvr80 to builtin, then I get:
> Backtrace:
> =>0 0xf7585c7c in libc.so.6 (+0x115c7c) (0x0194ea20)
>   1 0x7bc73fdb NTDLL_memcpy+0x2a(dst=0x194ea5c, src=0x0(nil), n=0x4)
> [/home/macnean/Programs/wine-1.3.24/dlls/ntdll/string.c:63] in ntdll
> (0x0194ea20)
>   2 0x00681546 in masseffect2 (+0x281545) (0x0194eb20)
>   3 0x00baa651 in masseffect2 (+0x7aa650) (0x0194ebf4)
>   4 0x00be16db in masseffect2 (+0x7e16da) (0x0194f070)
> Wierd since it was working for weeks now.  Sux, as I'm finally on the last
> mission.
> On Sat, Sep 3, 2011 at 4:27 PM, MacNean Tyrrell <dardack at gmail.com> wrote:
>> This is crazy.  Ok the msvcr80 is from a fresh wine prefix, the libc6 is
>> from my main Steam prefix.  All my other steam games work so far.  Also, wow
>> in direct x works (removed OpenGL option).  Also Mass Effect 2 loads up,
>> it's when it's asking to press a key to continue, I do that, as it fades to
>> black and the main menu would normally come up (it fades to black then
>> crashes) it crashes before the menu shows.
>> Trying to reinstall all of ME2.  Otherwise, I may have to reinstall Ubuntu
>> back down to 10.10 to see if that fixes it.  really sux too since I'm on the
>> last suicide mission right now.  So close to end.
>> --
>> Sincerely,
>> MacNean C. Tyrrell
> --
> Sincerely,
> MacNean C. Tyrrell


MacNean C. Tyrrell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-users/attachments/20110903/9e6eb265/attachment.html>

More information about the wine-users mailing list