[Wine] Anyone using Oneric suddenly having Wine/OpenGL problems?

3vi1 wineforum-user at winehq.org
Sat Sep 17 11:04:11 CDT 2011

So last night I try to start L4D2 (which previously worked), and am seeing this dreaded message as the first in the console:

err:wgl:X11DRV_WineGL_InitOpenglInfo  couldn't initialize OpenGL, expect problems

This is happening both with the latest Wine from git and from the prebuilt 1.3 package in the Oneiric repos.  It was all working fine when I last tested (using my git build) a few weeks back, and I haven't done anything peculiar with my graphics stack since then.

All other non-wine 3D apps, like Nexuiz and the Unity desktop w/compiz are happily working.

I don't think this is a Wine problem per se (could even be specific to my system), but it's odd that Wine is the only thing being affected.  Could this have something to do with the recent Ubuntu switch to multiarch?

I tried uninstalling/reinstalling the nvidia-current-updates package (and rebooting afterwards), and manually running ldconfig, but it had no effect.

evil at saturn:~$ glxinfo | grep 'direct rendering\| string'
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCI/SSE2
OpenGL version string: 4.1.0 NVIDIA 280.13
OpenGL shading language version string: 4.10 NVIDIA via Cg compiler

evil at saturn:~$ cat /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf 

If anyone has ideas of further things I could look at, I'd really appreciate hearing them.  I'm trying to investigate all avenues before I re-install the OS (as I suspect this might have something to do with this being a Natty install that I've updated all through the alphas).

Thanks in advance!

More information about the wine-users mailing list