[Wine] Starcraft 2 troubles

RealityBall wineforum-user at winehq.org
Wed Feb 15 20:47:10 CST 2012

Information you may need: my distro is Linux Mint 12 Gnome 
I am not dual booting with windows, I only have linux on this computer

Alright so the description for this problem is quite lengthy. Basically I set out to do something very simple in Linux. I wanted to install wine to be able to run starcraft 2. So the first thing I did was go to software manager. The latest version of wine I could have installed was 1.3. I went ahead and got it from there. Keep in mind I am relatively a noob when it comes to linux. Okay so I install 1.3 and I run the starcraft installer that I downloaded from the blizzard website. It is an exe file so I have to have wine to run it. Finally after opening and closing the installer for a few hours I get the starcraft 2 installer installed. So I run the installer and there is sound coming from it and everything is going peachy. Then after a while the sound stops and around 30% I get a runtime error. I have no idea why this is happening being the noob that I am but after that I decided to try to find my own solution. 

My own solution: Basically I looked at the wine downloads and I noticed I didn't have the latest version. So I decided to uninstall wine 1.3 via software manager and followed a tutorial and jumped through all the hoops required to build Wine 1.4-rc2 from source. After building it from source and adding packages beforehand as instructed from the tutorial I ran starcraft 2 again and it actually installed fine. I now have the patcher but it won't run! Another problem I am having is that in wine 1.3 I had sound while installing starcraft 2 while in the version I built 1.4 rc2 no sound comes from windows applications that should be coming from them (I think). 

What I did about this so far: I installed winetricks via terminal based on instructions in the wine-tricks page and tried throwing in a bunch of packages and changing some registry values via winetricks.   

Additionally: I went to the app database here http://appdb.winehq.org/objectManager.php?sClass=application&iId=11123 and tried all the suggested workarounds for the installer (there was only 1, installing ie6 via winetricks). I also did the work around for sound but due to the installer not being functional I am not sure if its working. 

What I would like to know: What exactly is different between the installations in terms of packages that run with wine? I am sure I must have had some packages in wine version 1.3 that I installed via software manager that I don't have now when installing a newer version of the software from source. 

Also I am not sure how to browse my C: drive without the gui assistance as well as submit detailed bug reports. 

[Image: http://i.imgur.com/M2TVH.jpg ]

More information about the wine-users mailing list