[Wine] Re: coreldraw 9 almost loads hangs at self regestration

zeeboos wineforum-user at winehq.org
Wed Jan 18 02:17:24 CST 2012

doug wrote:
> On 01/16/2012 03:10 PM, zeeboos wrote:
> > I am using wine 1.3.28 loaded from the Ubuntu software link (GUI) no terminal loading. I installed Ubuntu 64 bit on January 9 latest version. When I try to load Coreldraw 9 from the setup exe. file on the CD located in the DVD burner the program starts up fine and almost completely loads. (I used Wine to start the setup) Then it gets to self Registration and stops at c:/programs files/Corel/WT9Li.dll.  I tried winetricks and put a check mark in front of (MFC 40,   MFC 42   MSI, windows installer 2.0   and MSI Line services) They all say CHACHED under the status menu in winetricks now.  My Question is Does chached mean the process is done or is there something else I need to do to load these programs from winetricks. This is the first time I have used winetricks or tried loading a wine program.  So I am confused. I have only used linux a few days now so please keep that in mind when posting a reply.
> > 
> > 
> > 
> > 
> A few days ago, I tried to install Office X3 or Office X4 (I have both) 
> and I could not get either one of them to install.
> If and when you or someone finds out how to do this, I'd appreciate 
> hearing about it.  (I really only care about
> WordPerfect and Quattro.  Draw would be icing on the cake for me.)  If 
> it matters, I'm using pclos; its available version
> of Wine is 1.3.28.
> --doug

Doug I finally got Corel 9 to load but I am very disappointed in the results.
any tool with a flyout doesnt work. selecting fonts is almost impossible.  however I have some tips below of what I finally did to get it loaded.  I think this statement from Dimesio is the key "You probably didn't add the Wine PPA repository. http://www.winehq.org/download/ubuntu

If you still have problems after adding the repository, ask for help on the Ubuntu forum. "  

here is some more information that might help you Doug.

Some tips for others trying to load Coreldraw9.  My experience was when I tried to load Coreldraw via the 1.2 stable version using Ubuntu's software center I got locked out when trying to load the setup exe. file.  Wine was protecting me from viruses.  I can't remember exactly what it said but I do remember that is why Wine locked the setup file.  

Using Ubuntu's software center I then loaded version 1.3.28 beta.  When I right clicked on the setup exe. file in the CD it began to load and got all the way to self registering. 90% there and hung on c:/programs files/Corel/WT9Li.dll.  I tried winetricks MEC 40 and MFC 42 to no avail.

I finally uninstalled version 1.3.28 via Ubuntu's software center I did not use the terminal to uninstall.  From what I understand if its loaded by Ubuntu then you can uninstall using Ubuntu.  If wine is loaded by the terminal via binary code then I think its much more complicated to uninstall.  I could be wrong but that's the way I read things.  I have only been using Linux since January 9, 2012 Today is January 17, 2012.  Not much experience there.  The terminal is still intimidating to me.  But that's how I read things about installing and uninstalling.

After uninstalling version 1.3.28.  I then installed version 1.3.37 directly from this site because even thou Ubuntu would say get latest version it always gave me 1.3.28. I tried three different times and places using Ubuntu.

Finally I did have to copy and paste from this sites directions and pay very close attention and use the terminal.  I finally got 1.3.37 loaded.  This time when I right clicked the setup exe. Icon from the CD and used wine to install.  Corel asked if I wanted to start over or continue from the previous attempt.  Not in those words but that was the meaning.  I marked continue from last attempt because it said recommended.  This time it sailed through the missing dll.  When registering it would appear to be stuck but when I hit the escape key a box would come up saying registering is very important do you really want to quit. I would say no and it then I was led to the next step.  This happened several times. 

Finally I had the choice of trying to register on line or print a page and mail it in.  I choose print a page.  It did print the page!  A tip for those new to Corel`s registration, its long and  tedious but you only need to fill in the fields at the beginning with an asterisks.  Just click next after filling in the fields with asterisks, if you want to get through it quicker.  I have had this software since 2001 and love it for what I do.  I put a 10 page newspaper together every few months and am very familiar with its basic features.  I will give an update on how stable it is in wine in a day or two.   .Oh I am using Ubuntu 64 bit latest version loaded January 9, 2012.

More information about the wine-users mailing list