[Wine] Hype The Time Quest Regression

SpawnHappyJake wineforum-user at winehq.org
Mon Jan 30 23:24:56 CST 2012

There's an old Ubisoft game called "Hype the Time Quest".

For many Wine versions, Wine could not get past the Hype installer. It would go up to 117% and fail. Then a version came where if you unchecked the DirectX check, the install would work (or maybe that's all you had to do to begin with). But the game would fail to start with an error about MaiD3Dvr_bleu.exe. Then a Wine version came where the game actually worked, but needed a dinput override. And eventually a Wine version came where you didn't need to uncheck the the software test or do the override, and the game worked. Ok the exact chronological ordering might have been off a little, but that's more or less it.

Now we're back at square one with Wine 1.4 rc1. The installer fails without unchecking the software test. If you do uncheck it, I get the same old MaiDvr_bleu.exe error when I try to start the game.

To be more specific, Wine 1.3.29 was one of the first versions that could run Hype, but it needed the dinput override. Back in 1.3.29 you did have to uncheck that DirectX software test to keep the installer from failing.

It'd be sad to see functionality that's been so hard for Wine to obtain be lost and frozen that way in the next stable. So I hope you guys put it back before 1.4 is released.

Note: Wine has never been able to show the pre-game videos in Hype. But it did get the actual game running quite well. When I showed a friend the game working in Wine he said that Wine was running Hype more stably than one of the Windows versions did. Casting a fire spell crashed that Windows version he was talking about (95?), but Wine handled it.

And I did have the 1.4 Gecko installed when I was doing this.

So...helpful details....

I'm running Linux Mint 11 64-bit (yeah, haven't taken the time to upgrade, isn't that sad?), obviously I'm taking about Wine version 1.4 rc1, I'm running Hype in a completely clean prefix with the exception of Gecko being installed (that implies no Zeckensack's Glide wrapper), I'm running Hype in D3D mode rather than 3DFX mode (which becomes an option in the presence of Zeckensack's), Wine output in terminal says there was an unhandled fault on read access to memory and later gives a list of deferred stuff (those two things are a resurrection of how Wine used to not be able to run Hype - seems to be the same bug resurrected), and it's really the same old bug.

For example, I used to get this error back when Wine couldn't run Hype but could get past the installer the first time: https://lh5.googleusercontent.com/-CeRQTy_QZCI/ToRaPh5qc7I/AAAAAAAAAJU/OdXZC2_6DtM/Other%252520Error.png

Same error nowadays, except the bottom paragraph saying to report the bug isn't in the message any more and now there's a cool "Details" button in the error message. Who put that in; it's pretty cool? So I used the details button and got the backtrace and put it here: http://pastebin.com/7srywFKG.

Because people usually ask, here's my hardware info:

Dell XPS 8300
Intel i7-2600 processor 64-bit @3.4 GHz
Winbond Motherboard
8 gigs of SODIMM DDR3 RAM @ 1333 MHz, 4 two-gig sticks, only 4 slots
Winbond A03 BIOS
[SB X-Fi Xtreme Audio] CA0110-IBG (sound card)
ATI Redwood [Radeon HD 5670] (graphics card)

But mind you, last time we had this bug, it did not work on my laptop either (haven't tried laptop + Hype + Wine 1.4 rc 1 yet). So I really don't think it's a hardware issue. Especially given the bugs that Wine fixed to make it work. It has worked on my hardware in the past with earlier Wine versions, and now it isn't working on that same hardware with 1.4 rc1.

I'm also using the same installation and version of Linux now as when it was working.

If you want more details, see my entries in the AppDB: http://appdb.winehq.org/objectManager.php?sClass=version&iId=21609&iTestingId=66769

I give lots of detail there and shortcuts to lots of screenshots.

Hope this gets working again. You've done it once. You can do it again.


More information about the wine-users mailing list