[Wine] Issue with Steam after Steam update

boombatower wineforum-user at winehq.org
Thu Mar 8 16:10:56 CST 2012

I have been using Steam on suse for quite sometime without any issues, I updated to 12.1 and everything was still fine for months. After a Steam update a few weeks back Steam refused to load and instead pops up an error "Fatal Error: Could not load module 'bin/FileSystem_Steam.dll"

and produced the following in console: http://paste.kde.org/435782/

I have tried 32bit prefix and 64bit wineprefixes. I have followed the instructions on Steam's FAQ page and forum post (from many years back) on how to delete specific dlls so steam redownloads them. I have reinstalled many times, using winetrick and manually. Nothing seems to do the trick.

I am using the OSS ATI driver if that matters since I have read things that hint at the driver being an issue when the opengl dlls don't load, but it would seem that should be a different error. I have check and the opengl dlls on installed on my system.

I am using wine 1.4 (now), but have been running steam through a variety of versions. I have tried backing off to much older versions and it still does not work.

I have a friend with the same video card and OSS driver installed on a suse 12.1 box with other differences in hardward. After I discovered the issue I made sure to ask him to update Steam without making any changes to his box (just incase I had forgotten and I had made changes). He had steam running fine, it told him he had an update, he updated, and then same error.

The error about filesysystem.dll appears to be an issue that people have had on and off on windows with Steam and considering it appeared again with a recent Steam update I figured I would start seeing lots of posts about it as everyone else updated, but I have not. Any thoughts on what else I might try?

More information about the wine-users mailing list