[Wine] Doom Builder 2

Super Jamie wineforum-user at winehq.org
Sat Mar 10 19:25:28 CST 2012

Doom Builder 2 is a .Net 2.0 application which used to work fairly well in Wine 1.3.36 and .37 (appdb entry (http://appdb.winehq.org/objectManager.php?sClass=version&iId=12221)).

Now with 1.4, the app still installs fine (after winetricks dotnet20) however opening a map displays an error "Unable to initialize Direct3D video device" and the following terminal output:

Initializing graphics device...
err:d3d:context_create wglSwapIntervalEXT failed to set swap interval 0 for context 0x200cc8, last error 0x591

Any ideas?

If you need a wadfile to test, you can get one from the GPL-licensed Freedoom (http://www.nongnu.org/freedoom/).

More information about the wine-users mailing list