[Wine] Forsaken World - A pretty unique problem

psychodr wineforum-user at winehq.org
Sun Mar 25 13:56:42 CDT 2012


I'm trying to run the game Forsaken World (fw.perfectworld.com/) on Fedora 14 using the version 1.3.24 of wine. When I try running it normally, everything works perfectly fine, i can play for some time, but at random times the game just crashes, and it happens quite often (about 15 times if I play it for 1 hour). The error is: "X Error of failed request:  BadAccess (attempt to access private resource denied)" and something else. To me it looked like a permission error, so I tried running the game as root. When I try running it as root, neither the NPCs nor the pets show up (I was using custom graphics settings)! Then I tried running it on the default settings, and the NPCs are there, but the game is totally unplayable... The camera is glitched,and its not on full screen.

What could possibly be causing this error? Why do the NPCs show up only if I use the default settings? Does anyone know how to fix this?

Thank you  [Wink]

More information about the wine-users mailing list