[Wine] Wine refusing to create a configuration directory there

PG wineforum-user at winehq.org
Wed Mar 28 04:23:39 CDT 2012


I am new on the forum, and apologize in advance if this question  was answered somewhere else -I looked up, but couldn't find it. 

This is NOT an issue with running wine as root; I am NOT trying to do that. Just so everybody knows!

I am using MacOS 10.7.3 on a late 2011 MacBook Pro, and Wine used to work on it up until last week (it had been ported from a preceding Snow Leopard machine).

Unfortunately something happened, and I had to reinstall it -and can't. The install itself works, but wen I try either to winecfg, or to open an .exe file (same difference, I gather), I get this Terminal message:

MacBook-4:~ pierregervais$ winecfg
wine: '/Users/pierregervais' is not owned by you, refusing to create a configuration directory there

As you see, I am NOT working under the root shell. However, for some reason the wine process, which was installed at the root -and from what I read there is no other way- decides that it is not allowed to write into my Home Directory. Of course I could sudo evrything, but this would be tantamount to running wine in root, wouldn't it? And I fully agree with the rule which forbids that.

Install: I tried two ways, first the way I had installed it on Snow Leopard,


with the special PATH commands after MacPorts

then a more streamlined way


without any PATH terminal fiddling.

Either way ends up in the same mistake. 

All this may be created by a permissions issue on my Mac; I tried reparing permissions of course, to no avail...

Any help, hint, or pointer would be deeply appreciated. I am not a very compeent user, and know probably way not enough about the structure of permissions. But Installing Wine seemed, and was straightforward the first time out, and I can't figure out what I am doing wrong here!

Pierre Gervais

More information about the wine-users mailing list