[Wine] Winasio, somebody know how make it work??

jordan triplesquarednine at gmail.com
Wed May 2 12:45:27 CDT 2012

On Wed, May 2, 2012 at 12:46 PM, Splashman <wineforum-user at winehq.org> wrote:
> Wineasio is for both u can find the 32 and 64bit compilations and inside the makefile in the sources they explain you must  specify where is your wine path in the 64 bits compilations in /usr/lib/ or /usr/lib/etcetc../wine/ or correct it and copy the file manually the point of jack is what i am not sure at all, this --mixed  ive never heard after i just installed from synaptic, the thing is i can watch the dll inside the library menu in winecfg but not his options in regedit i think that is the point becouse is not registered.

please post where in the makefile it says -m64??? i can point you to
where it DOESN'T;

CEXTRA                = -m32 -g -O2 -D__WINESRC__ -D_REENTRANT -fPIC
-Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement
-Wwrite-strings -Wpointer-arith
CXXEXTRA              = -m32 -D__WINESRC__ -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement
-Wwrite-strings -Wpointer-arith

do you see any 64bit C/CXXFLAGS?? -> i dont. but i do see -m32 which
is telling gcc to compile 32bit. you require multilib to run wineASIO
on a 64bit system. As to where wineasio.dll.so goes -> /usr/lib32/wine

I've also tried to install wineASIO on a 64bit prefix (by accident)
and got the EXACT same error as you are posting. but if you want to
make the assumption that i haven't been using wineASIO for years on a
64bit system, than go right ahead. - in the end that won't be my

On the jack note; I would assume Ubuntu packages jack2 with --mixed
... but since i don't use ubuntu - i couldn't tell you. There probably
is a lib32-jack package or something like that. Jack also requires
32bit support, because wineASIO is 32bit.

good luck

More information about the wine-users mailing list