[Wine] Installers of any kind don't working.

Caencel wineforum-user at winehq.org
Sun May 6 13:32:28 CDT 2012

Suddenly Wine is not installing programs from any kind of installer, which perfectly could just some days ago, a good example is with the game Bejeweled 3 that i installed with no problems last week, i'm using Wine 1.5.3 from ubuntu wine PPA in Xubuntu 12.04 32 bits and a clean .wine prefix, and this is the output in terminal:


$ wine "Bejeweled 3.exe"
err:virtual:map_image failed to set 60000020 protection on section .text, noexec filesystem?
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (
wine: Unhandled page fault on read access to 0x00402fb9 at address 0x402fb9 (thread 0009), starting debugger...
err:virtual:map_file_into_view failed to set 00000005 protection on file map, noexec filesystem?
err:virtual:NtMapViewOfSection map_file_into_view 0x340000 c932000 000000000 failed
couldn't load main module (5)
Unhandled exception: page fault on read access to 0x00402fb9 in 32-bit code (0x00402fb9).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
 EIP:00402fb9 ESP:0032fe74 EBP:0032fe88 EFLAGS:00210212(  R- --  I   -A- - )
 EAX:00000000 EBX:7b89aff4 ECX:0032fef0 EDX:0032fef0
 ESI:7ffdf000 EDI:00402fb9
Stack dump:
0x0032fe74:  7b85a5ac 7ffdf000 7bc4bd4a 7b89aff4
0x0032fe84:  7ffdf000 0032fec8 7b85b81f 7ffdf000
0x0032fe94:  00402fb9 00000000 00000000 00000000
0x0032fea4:  00000000 00000000 00000000 00000000
0x0032feb4:  00000000 00000000 7bca6ff4 bffca514
0x0032fec4:  001107c8 0032fed8 7bc71d80 7ffdf000
=>0 0x00402fb9 (0x0032fe88)
  1 0x7b85b81f in kernel32 (+0x4b81e) (0x0032fec8)
  2 0x7bc71d80 call_thread_func_wrapper+0xb() in ntdll (0x0032fed8)
  3 0x7bc7485d call_thread_func+0x7c() in ntdll (0x0032ffa8)
  4 0x7bc71d5e RtlRaiseException+0x21() in ntdll (0x0032ffc8)
  5 0x7bc49f4e call_dll_entry_point+0x61d() in ntdll (0x0032ffe8)
0x00402fb9: call    0x00405dea
Module    Address            Debug info    Name (59 modules)
PE    71590000-71617000    Deferred        comctl32
ELF    7b800000-7ba2f000    Dwarf           kernel32<elf>
  \-PE    7b810000-7ba2f000    \               kernel32
ELF    7bc00000-7bcc3000    Dwarf           ntdll<elf>
  \-PE    7bc10000-7bcc3000    \               ntdll
ELF    7bf00000-7bf04000    Deferred        <wine-loader>
ELF    7e296000-7e30b000    Deferred        rpcrt4<elf>
  \-PE    7e2a0000-7e30b000    \               rpcrt4
ELF    7e30b000-7e413000    Deferred        ole32<elf>
  \-PE    7e320000-7e413000    \               ole32
ELF    7e429000-7e42f000    Deferred        libxfixes.so.3
ELF    7e42f000-7e43a000    Deferred        libxcursor.so.1
ELF    7e4c4000-7e4ee000    Deferred        libexpat.so.1
ELF    7e4ee000-7e522000    Deferred        libfontconfig.so.1
ELF    7e522000-7e532000    Deferred        libxi.so.6
ELF    7e532000-7e536000    Deferred        libxcomposite.so.1
ELF    7e536000-7e53f000    Deferred        libxrandr.so.2
ELF    7e53f000-7e549000    Deferred        libxrender.so.1
ELF    7e549000-7e54f000    Deferred        libxxf86vm.so.1
ELF    7e54f000-7e553000    Deferred        libxinerama.so.1
ELF    7e553000-7e575000    Deferred        imm32<elf>
  \-PE    7e560000-7e575000    \               imm32
ELF    7e575000-7e57c000    Deferred        libxdmcp.so.6
ELF    7e57c000-7e59d000    Deferred        libxcb.so.1
ELF    7e59d000-7e5b7000    Deferred        libice.so.6
ELF    7e5b7000-7e6eb000    Deferred        libx11.so.6
ELF    7e6eb000-7e6fd000    Deferred        libxext.so.6
ELF    7e6fd000-7e706000    Deferred        libsm.so.6
ELF    7e706000-7e78f000    Deferred        winex11<elf>
  \-PE    7e710000-7e78f000    \               winex11
ELF    7e78f000-7e7a5000    Deferred        libz.so.1
ELF    7e7a5000-7e83f000    Deferred        libfreetype.so.6
ELF    7e83f000-7e85e000    Deferred        libtinfo.so.5
ELF    7e85e000-7e880000    Deferred        libncurses.so.5
ELF    7e89e000-7e908000    Deferred        shlwapi<elf>
  \-PE    7e8b0000-7e908000    \               shlwapi
ELF    7e908000-7eb1a000    Deferred        shell32<elf>
  \-PE    7e910000-7eb1a000    \               shell32
ELF    7eb1a000-7eb7c000    Deferred        advapi32<elf>
  \-PE    7eb30000-7eb7c000    \               advapi32
ELF    7eb7c000-7ec3a000    Deferred        gdi32<elf>
  \-PE    7eb90000-7ec3a000    \               gdi32
ELF    7ec3a000-7ed7a000    Deferred        user32<elf>
  \-PE    7ec50000-7ed7a000    \               user32
ELF    7ef7a000-7ef87000    Deferred        libnss_files.so.2
ELF    7ef87000-7ef93000    Deferred        libnss_nis.so.2
ELF    7ef93000-7efad000    Deferred        libnsl.so.1
ELF    7efad000-7efb6000    Deferred        libnss_compat.so.2
ELF    7efb6000-7efe2000    Deferred        libm.so.6
ELF    7efe3000-7efe7000    Deferred        libxau.so.6
ELF    7efe7000-7f000000    Deferred        version<elf>
  \-PE    7eff0000-7f000000    \               version
ELF    b7463000-b7468000    Deferred        libdl.so.2
ELF    b7468000-b760d000    Deferred        libc.so.6
ELF    b760e000-b7629000    Deferred        libpthread.so.0
ELF    b7640000-b7646000    Deferred        libuuid.so.1
ELF    b7647000-b7789000    Dwarf           libwine.so.1
ELF    b778b000-b77ad000    Deferred        ld-linux.so.2
ELF    b77ad000-b77ae000    Deferred        [vdso].so
process  tid      prio (all id:s are in hex)
00000008 (D) D:\H.Misc\Bejeweled 3\Bejeweled 3.exe
    00000009    0 <==
0000000e services.exe
    00000029    0
    00000028    0
    00000021    0
    00000019    0
    00000018    0
    00000017    0
    00000015    0
    00000010    0
    0000000f    0
00000012 mscorsvw.exe
    0000001b    0
    0000001a    0
    00000014    0
    00000013    0
0000001c winedevice.exe
    00000024    0
    00000023    0
    00000020    0
    0000001d    0
0000001e explorer.exe
    0000001f    0
00000025 plugplay.exe
    0000002a    0
    00000027    0
    00000026    0

i tried downloading the latest wintricks file and downloading components such as dotnet2.0 and msi2, also tried with other versions of wine in my repos and with other kernels but still no luck, i'm clueless and since i can't really tell what's in the output i have no idea what to do, any help would be great, greetings.

More information about the wine-users mailing list