[Wine] Skyrim in Fedora

patrick wineforum-user at winehq.org
Fri May 18 10:51:09 CDT 2012

I was able to run Skyrim on my PC using ubuntu 11.10. Now, using Fedora 17, I am having a strange issue that I cannot find reported anywhere else.

Steam is installed, HL and HL2 and all their variants run great.

When I launch Skyrim from Steam, I am presented with the SkyrimLauncher, when I launch the game from here, the window presented is full of garbage (it is a mishmash of things previously drawn on the screen). The odd part is that the audio kicks in, and I can even press enter, start a new game, and hear all the sounds associated, but I never get any video output in the window. It stays a static bunch of garbage.

The results are the same with the nouveau drivers and the proprietary nvidia drivers. I have tried with GLSL disabled and OffscreenRendering set to backbuffer with no difference noticed.

This is a the output of launching steam, selecting Skyrim, and sitting at the main menu listening to the chanting music, then killing Skyrim and closing steam.

This is a lovely screenshot:


patrick at crudora:~$ uname -a
Linux crudora.schiznet 3.3.4-4.fc17.x86_64 #1 SMP Fri May 4 17:25:07 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

patrick at crudora:~$ yum list installed wine*
Installed Packages
wine.i686                                                         1.5.3-1.fc17                                    @updates-testing
wine-alsa.i686                                                    1.5.3-1.fc17                                    @updates-testing
wine-capi.i686                                                    1.5.3-1.fc17                                    @updates-testing
wine-cms.i686                                                     1.5.3-1.fc17                                    @updates-testing
wine-common.noarch                                                1.5.3-1.fc17                                    @updates-testing
wine-core.i686                                                    1.5.3-1.fc17                                    @updates-testing
wine-courier-fonts.noarch                                         1.5.3-1.fc17                                    @updates-testing
wine-desktop.noarch                                               1.5.3-1.fc17                                    @updates-testing
wine-fonts.noarch                                                 1.5.3-1.fc17                                    @updates-testing
wine-ldap.i686                                                    1.5.3-1.fc17                                    @updates-testing
wine-marlett-fonts.noarch                                         1.5.3-1.fc17                                    @updates-testing
wine-ms-sans-serif-fonts.noarch                                   1.5.3-1.fc17                                    @updates-testing
wine-openal.i686                                                  1.5.3-1.fc17                                    @updates-testing
wine-pulseaudio.i686                                              1.5.3-1.fc17                                    @updates-testing
wine-small-fonts.noarch                                           1.5.3-1.fc17                                    @updates-testing
wine-symbol-fonts.noarch                                          1.5.3-1.fc17                                    @updates-testing
wine-system-fonts.noarch                                          1.5.3-1.fc17                                    @updates-testing
wine-systemd.noarch                                               1.5.3-1.fc17                                    @updates-testing
wine-tahoma-fonts.noarch                                          1.5.3-1.fc17                                    @updates-testing
wine-twain.i686                                                   1.5.3-1.fc17                                    @updates-testing

patrick at crudora:~$ yum list installed *nvidia
Installed Packages
akmod-nvidia.x86_64                                         1:295.49-1.fc17.4                                   @rpmfusion-nonfree
xorg-x11-drv-nvidia.x86_64                                  1:295.49-1.fc17                                     @rpmfusion-nonfree

Thank you for any help/advice! Let me know if you would like any more information.

More information about the wine-users mailing list