[Wine] Re: DirectSoft 5 Serial communications Issue's

samuraimarc wineforum-user at winehq.org
Mon May 21 16:33:45 CDT 2012

> That's very old version of Wine. Have you tried using a more recent 
> version?

I tried v1.4 with the same results

> 1) what happens if you change the access permissions but don't create
> the symlink?

I have not tried this, with out the symlink what do I tell it to connect to with no com*

> 2) what does the command "setserial /dev/ttyS0" show you? 
> On my system it shows:  
> /dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
> so you should see something similar. 

I get: /dev/ttyS0. UART: 16550A. Port: 0x8010, IRQ: 16

I failed to mention that I'm using a pcmcia card with 2 serial ports on it. 

dmesg | grep tty

Gives me: 
[    7.663918] 0000:16:00.0: ttyS0 at I/O 0x8010 (irq = 16) is a 16550A
[    7.664392] 0000:16:00.0: ttyS1 at I/O 0x8018 (irq = 16) is a 16550A

> ln -s /dev/ttyS0 ~/.wine/dosdevices/COM1:

I've tried all sorts of COM* com* with no effect, or are you talking about the colon on the end?


More information about the wine-users mailing list