[Wine] keyword "msgctxt" unknown to compile on SLE10 SP4

flako wineforum-user at winehq.org
Tue May 22 15:44:07 CDT 2012

Hello, I'm trying to compile "Wine 1.4" in SLED 10 SP4, which is:

Linux # 1 SMP i686 i686 i386 GNU / Linux

The  ./Configure not found:
configure: XInput2 headers not found, the XInput 2 extension won't be supported.   
configure: OpenCL development files not found, OpenCL won't be supported. 
configure: libdbus development files not found, no dynamic device support. 
configure: libgnutls development files not found, no schannel support.
configure: libv4l development files not found. 
configure: gstreamer-0.10 base plugins development files not found, gstreamer support disabled 
configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
configure: libmpg123 development files not found (or too old), mp3 codec won't be supported. 
configure: libopenal development files not found (or too old), OpenAL won't be supported.  

Where the files:
http://cdaeccaeddd3f.comeze.com/foros/sled10SP4.log - Contains all installed packages
http://cdaeccaeddd3f.comeze.com/foros/configure.log  - Contains the log ./configure
http://cdaeccaeddd3f.comeze.com/foros/make.log - Make the log completely.

The summary error log is:

./tools/winebuild/winebuild  -w --def -o dlls/xinput1_3/libxinput.def --export ./dlls/xinput1_3/xinput1_3.spec                                                               
msgfmt -o po/ar.mo po/ar.po   
po/ar.po:359: keyword "msgctxt" unknown
po/ar.po:359:8: parse error
po/ar.po:591: keyword "msgctxt" unknown
po/ar.po:591:8: parse error
po/ar.po:596: keyword "msgctxt" unknown
po/ar.po:596:8: parse error
po/ar.po:1157: keyword "msgctxt" unknown
po/ar.po:1157:8: parse error
po/ar.po:1310: keyword "msgctxt" unknown
po/ar.po:1310:8: parse error
po/ar.po:1837: keyword "msgctxt" unknown
po/ar.po:1837:8: parse error
po/ar.po:1850: keyword "msgctxt" unknown
po/ar.po:1850:8: parse error
po/ar.po:1851: duplicate message definition  
po/ar.po:361: ...this is the location of the first definition         
po/ar.po:1868: keyword "msgctxt" unknown  
po/ar.po:1868:8: parse error  
po/ar.po:3071: keyword "msgctxt" unknown 
po/ar.po:3071:8: parse error  
po/ar.po:3133: keyword "msgctxt" unknown  
msgfmt: too many errors, aborting   
make: *** [po/ar.mo] Error 1 

Not sure if the problem is due to gettext or XInput.

Any ideas?. xinput try to disable the  "- without-xinput - without-xinput2" but still says the same error, also probe ". / Tools / wineinstall" with the same result.

Not sure if it is a problem that is solved by installing X library, or just not going to be able to compile the latest version of wine in SLED 10 SP4.

If I aimed it more read, the agradecere .. As always I thank you reach here. (Sorry have used google trasnlate)

More information about the wine-users mailing list