[Wine] Tahoma stopped being anti-aliased

Martin Schrodt martin at schrodt.org
Sun Jan 8 16:28:51 CST 2017

Today, I reverted my Arch Linux installation back to not using the
infinality patches for fontconfig and freetype. Since then, the Tahoma
in wine is not antialiased any more. I have the original Tahoma from
Windows10, and it worked with that font before.

I tried lots of things:

* moving the "DPI slider" (winecfg/Graphics/Screen Resolution): At the
default 96 DPI, it looks shitty, when moving the slider, it becomes
antialiased around 120 DPI, so it certainly seems that something
disables this below certain sizes

* Rendering the font with gnome-font-viewer at such a small size -> it
is antialiased, so this is wine-related somehow

* run winecfg with a fresh WINEPREFIX: same result

* substitute the Tahoma in wine's registry with Roboto: works, it uses
Roboto, and it is antialiased

* search /etc/fonts for anything that will prevent antialiasing: grep
for "pixelsize", "antialiasing" -> there's nothing in the fontconfig

Any clues on where to look next?

Thank you,

More information about the wine-users mailing list