<br><br><div class="gmail_quote">On Sat, Sep 3, 2011 at 11:49 AM, dimesio <span dir="ltr"><<a href="mailto:wineforum-user@winehq.org">wineforum-user@winehq.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div class="im"><br>
Thaodan wrote:<br>
> with wine 1.3.15 they were working<br>
<br>
</div>No, they weren't. Wine prior to 1.3.26 was using the 64 bit glib headers, and producing a broken winegstreamer. A patch was added in 1.3.26 to prevent this from happening. In current wine, gstreamer support is disabled if the 32 bit headers are not found.<br>

<br>
Note that even if you do have the 32 bit headers installed, you have to use 32 bit pkg-config when running ./configure or it will still pick up the 64 bit headers. <a href="http://www.winehq.org/pipermail/wine-devel/2011-August/091415.html" target="_blank">http://www.winehq.org/pipermail/wine-devel/2011-August/091415.html</a><br>

<br>
<br>
<br></blockquote><div><br></div><div>Ok I read that.  I'm still confused.  I'm just curious if i have this right: so on ubuntu the ia32-lib files have the correct gstreamer headers for 32 bit, however, pkg-config isn't picking them up (it picks up the 64bit headers), so you have to do something special to tell ./configure the 32bit gstreamer headers are there? Otherwise it says gstreamer support disabled (this is what I get)?</div>
<div><br></div><div>If my understanding is correct, then how would you get ./configure with 32bit pkg-config to find the 32bit gstreamer headers?</div></div><br><br clear="all"><div><br></div>-- <br>Sincerely, <br><br>MacNean C. Tyrrell<br>