[Bug 22434] Hype - The Time Quest crashes when the game should come up (looks like null pointer dereference to me)

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Apr 24 04:44:58 CDT 2011


--- Comment #19 from cvoeten at gmail.com 2011-04-24 04:44:58 CDT ---
The game has worked on Windows all the way from Windows 98 (I don't know what
GPU our ancient Windows 98 computer had but it certainly wasn't anything fancy)
up to Windows XP (with the Intel GPU). I believe my mom's 32-bit Vista was also
able to run it.

On my new computer (64-bits, Windows 7 & Gentoo Linux, ATI Radeon HD 5450 &
Intel integrated i5 GPU), the game still does not run on Wine with exactly the
same problem as before:

fixme:win:EnumDisplayDevicesW ((null),0,0x33f518,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f614,0x00000000), stub!
fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to
fixme:d3d:swapchain_init Add OpenGL context recreation support to

This is from my Intel GPU. If I run the game on my Radeon GPU I get some more
errors related to wine not particularly liking gallium3d and gallium3d not
supporting some things wine wants, etc. That's not a problem on wine's end. (Of
course I'd happily plug my monitor into my Intel GPU if it means being able to
play this game again).

To make things a bit more complicated, this game does not run on my new Windows
OS: the game doesn't appear to play nice with 64 bits Windows. However, I still
have my old computer with the Intel GPU and Windows XP (32-bit), and the game
still works on that box. I'd happily dig it up again for testing purposes if
you need me to.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list