Traditional Chinese (CP950) not displaying in WINE

Anthony Fok anthony at
Tue Feb 26 01:54:23 CST 2002

Hello Dmitry,

On Sun, Feb 24, 2002 at 07:32:09PM +0800, Dmitry Timoshkov wrote:
> "Anthony Fok" <anthony at> wrote:
> > We are experimenting some problems with displaying and inputting
> > Chinese characters in WINE (January 2002 or newer).  For example, most
> > Chinese characters show up as squares,
> Probably some font misconfiguration problem. Apparently displaying of
> Chinese characters should work since output of Japanese characters
> admittedly works.

Thanks for your advice.  After tweaking the font settings ~/.wine/config,
we were able to get notepad to display Chinese text.  However, it seems to
only work with bitmap fonts like -taipei-*-; it had some problems with the
Arphic TrueType fonts that it seems Wine was using a different character set
to display the characters.  We'll do more investigation.  :-)

> > and it seems that WINE doesn't accept Chinese input via XCIN (an input
> > method server using the XIM protocol).  Did we misconfigured something? 
> > Or is this a known problem in WINE?  Any pointers would be appreciated. 
> > Thanks!
> I'm afraid that correct input of Chinese and any multibyte characters
> will require almost complete rewrite of the Wine keyboard code using
> X Input Method/Input Context. Simultaneously it will solve the problem
> with dead keys.
> Unfortunately nobody worked on that problems yet. Do you want to try?

Yes, we are willing to give it a try.  How big a task is this?  Where should
we start?  Which files need to be modified?  (I am new to Wine, so any
starters/pointers would be helpful.)  :-)  Many thanks for your help!



Anthony Fok Tung-Ling
ThizLinux Laboratory   <anthony at>
Debian Chinese Project <foka at>
Come visit Our Lady of Victory Camp! 

More information about the wine-devel mailing list