Unhandled exception in old DOS application

Medland, Bill Bill.Medland at accpac.com
Tue May 14 10:15:33 CDT 2002

> -----Original Message-----
> From: M.H.VanLeeuwen [mailto:vanl at megsinet.net]
> Sent: Monday, May 13, 2002 7:33 PM
> To: wine-devel at winehq.com
> Subject: Unhandled exception in old DOS application
> Hi,
> I hope this is the correct place to ask...
> Up until the 20020411 wine release my old DOS application 
> worked well...for the
> last ~2 years. (Thanks all of you!)
> With both 20020411 and 20020509 releases the wine issues an 
> Unhandled exception
> report and starts the debugger.
> bash-2.05$ wine cardload.exe -- -a340 
> -f"c:\\\winapps\\\winphone\\\cardload.hex"
> Could not stat /mnt/fd0 (No such file or directory), ignoring drive A:
> Warning: unprotecting the first 64KB of memory to allow 
> real-mode calls.
>          NULL pointer accesses will no longer be caught.
> wine: Unhandled exception, starting debugger...
> err:int:DOSVM_Loop MsgWaitForMultipleObjects returned 
> unexpected value.
> This application just downloads firmware (cardload.hex) to an 
> old ISA card.
> What can be done to fix this, where should I begin looking to 
> fix it, who

The first thing I'd do is see which "fix" broke it.  That requires getting
the code out of the cvs itself.  Basically I do an almost binary search
between when I know it "worked" and when I know it failed and what area of
code was affected.

More information about the wine-devel mailing list