Wine CVS Build Error

Casey McGinty casey at
Sun Aug 10 13:07:10 CDT 2003

I'm trying to get Wine and/or Winex to build on my system with no luck.

I get the same error in both releases, I was hoping someone would know
how to fix this, or what I am doing wrong.

I'm using GCC 3.2.3 and kerenl 2.4.21 on a Linux From Scratch

The error output I get in Wine:

gcc -s -c -I. -I. -I../../include -I../../include  -D_REENTRANT -fPIC
-D__WINESRC__ -DDLLDIR="\"/usr/local/lib/wine\"" -Wall
-mpreferred-stack-boundary=2 -gstabs+ -Wpointer-arith  -O3
-march=athlon-xp -fforce-addr -fomit-frame-pointer -funroll-loops
-frerun-cse-after-loop -frerun-loop-opt -falign-functions=4 -o ldt.o
ldt.c: In function `modify_ldt':
ldt.c:78: `SYS_modify_ldt' undeclared (first use in this function)
ldt.c:78: (Each undeclared identifier is reported only once ldt.c:78:
each function it appears in.) make[2]: *** [ldt.o] Error 1 make[2]:
Leaving directory `/tmp/wine-20030709/libs/wine' make[1]: *** [wine]
make[1]: Leaving directory `/tmp/wine-20030709/libs' make: *** [libs]
Error 2

The error is basically the same in Winex, undefined SYS_modify_ldt. I
tried searching for SYS_modify_ldt definition in my kernel sources and
the Wine source and I failed to find anything. What gives ?

I hope someone can help me with this. Thanks

- Casey

More information about the wine-devel mailing list