Compiling WINE - Hopeless situation? :)

Dan Kegel dank at
Sun Mar 30 01:54:16 CST 2003

Sylvain wrote:
>  --- Michael Stefaniuc <mstefani at> a écrit : > On Sun, Mar 30,
> 2003 at 12:44:31AM +0100, Sylvain Petreolle wrote:
>> > The code that has problem for now is C code, not C++, am I right
>> here ?
>> > Then it has nothing to do with C++ thing.
>> Yeah, but the page you pointed to is for C++ incompatibilities, not
>> C.
>> And a newer 2.96 is stable for C.
> If there is one, it isnt shipped with RH 8, or not by default.

Red Hat 8 uses gcc3.2.  If you have Red Hat 8, you don't need gcc2.96.

> "Current snapshots of GCC, and any version labeled 2.96, produce object
> files that are not compatible with those produced by either GCC 2.95.2
> or the forthcoming GCC 3.0."

This is true only for C++.  For C code, Red Hat's gcc2.96's have been
just fine.

- Dan

Dan Kegel

More information about the wine-devel mailing list