CopyFile fails sometimes

Fabian Cenedese Cenedese at
Thu Feb 12 06:37:42 CST 2004

>>FILE: FILE_CreateFile: /home/fabi/winec/imp2/Config/_ConfigurationType._TemplInfoLinkMaster_
>There are several files like that but in the destination directory I get only one
>single file with the name "_ConfigurationType" with which they all begin with.
>The content is the one from the last file being copied. So it looks like the
>CreateFile somehow messed up the name as everything else worked and
>copied all files over each other. I traced it until the call to the server in
>FILE_CreateFile. I only had a look at the server code but couldn't see anything
>where the filename is analyzed (except for .exe and .com). Other files are
>copied without any problem, with or without extension, even extensions longer
>than 3 chars.
>But it gets even weird. My copy tool is a Win32 CLI app. I have a batch
>file which calls this copy tool to copy several files (of course). If this batch
>file again is called from a Win32 MFC+GUI app I get this described error. But
>if I call it directly with wineconsole batch.bat the whole copying works.
>So it may have to do with execution/redirection. But I'm out again.

Actually that's wrong :)  It works if I call the copy tool directly with wine.
But calling the batch file with wineconsole gives the same error. So it
could be that wineconsole/batch files/dos mode/whatever don't like
the very long extensions or the chars contained. Yep, it doesn't like
the _ after the dot. After removing the underscore it works also with
the wineconsole. Any ideas?

bye  Fabi

More information about the wine-devel mailing list