slight trouble running winetests under windows

chmorgan at chmorgan at
Tue Jan 13 10:59:39 CST 2004

Ahh yes, this appears to be the issue.  If I go to "project settings->link->object/library modules" and add "uuid.lib" to the list then the test compiles without many other issues.  Shouldn't the script be adding this to the .dsp/.dsw?

I'm having great troubles compiling the test against vs6 header files as well, should I upgrade to the latest platform sdk?

The wine headers work pretty well except for errors from the compiler about not being able to convert __uint64 to double.


> From: Hans Leidekker <hans at>
> Date: 2004/01/13 Tue AM 05:20:29 EST
> To: wine-devel <wine-devel at>
> CC: Chris Morgan <cmorgan at alum.WPI.EDU>
> Subject: Re: slight trouble running winetests under windows
> On Tuesday 13 January 2004 05:47, Chris Morgan wrote:
> > I'm trying to get some of the wine tests compiling and running under
> > windows, oleaut32 test specifically.  I've got the project file built and
> > everything opens fine under visual studio 6.  The only issue is that during
> > linking of the oleaut32 tests _IID_IFont is undefined.  Oddly enough if I
> I get these linking errors too when compiling with MinGW. I solve
> these by manually adding -luuid. The dsound test needs -luuid and
> -ldxguid to link. There has been some discussion in the past as to
> how to solve this. I proposed a number of changes to Wine's build
> system to fix this but they were rejected.
> Let's see if I can sum up the issues. In Wine uuids are put in
> a lib called libwine_uuid. It's called like that because a
> libuuid already exists. Second thing is that in MinGW and MSVC
> there are two separate libraries with uuids, uuid and dxguid,
> whereas in Wine they're all in one.
>  -Hans

More information about the wine-devel mailing list