Fwd: Wine install fails on Gentoo with `SYS_sigaction' undeclared

Alex Woods wine-devel at giblets.org
Sat Mar 26 14:58:35 CST 2005

On Sat, Mar 26, 2005 at 06:02:43PM +0100, Ferenc Wagner wrote:
> I think this message better fits here on the devel list.

Actually, it would fit better on a Gentoo forum.  This is a problem with
building on Gentoo 2004.3.  It's fixed in the 2005.0 development
version, and is to do with the fact that the multilib headers are absent
with from the 2004.3 binary emul-x86 package.  This means you build
against the x86_64 headers, which have totally different sigactions.
Upgrading to 2005.0 will sort out the problem but can be quite
problematic in itself ;)
The other thing you can do is get the /usr/include directory from an x86
box and temporarily replace your /usr/include with that, then build
wine.  This is what I did before I got an answer from the Gentoo devs,
and works fine.

> -------------------- Start of forwarded message --------------------
> From: "Jonathan Duncan" <googlegroups at nacnud.com>
> Newsgroups: comp.emulators.ms-windows.wine
> Date: 25 Mar 2005 10:26:46 -0800
> Message-ID: <1111775206.112993.209430 at f14g2000cwb.googlegroups.com>
> I downloaded "Wine-20050310.tar.gz"
> Untar/zipped it.
> Entered the directory "wine-20050310"
> Typed "./configure" -> Success
> Typed "make depend" -> Success
> Typed "make" -> The following is the last of the make process:
> -------------------------------------------------------------
> gcc -m32 -c -I. -I. -I../../include -I../../include  -D__WINESRC__
> -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+
> -Wpointer-arith  -g -O2 -o server.o server.c
> gcc -m32 -c -I. -I. -I../../include -I../../include  -D__WINESRC__
> -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+
> -Wpointer-arith  -g -O2 -o signal_i386.o signal_i386.c
> signal_i386.c: In function `wine_sigaction':
> signal_i386.c:114: error: `SYS_sigaction' undeclared (first use in this
> function)
> signal_i386.c:114: error: (Each undeclared identifier is reported only
> once
> signal_i386.c:114: error: for each function it appears in.)
> make[2]: *** [signal_i386.o] Error 1
> make[2]: Leaving directory
> `/home/jduncan/downloads/wine-20050310/dlls/ntdll'
> make[1]: *** [ntdll] Error 2
> make[1]: Leaving directory `/home/jduncan/downloads/wine-20050310/dlls'
> make: *** [dlls] Error 2
> -------------------------------------------------------------
> I have tried this as a regualar user and as root.
> I have tried "./tools/wineinstall".
> I have tried "make distclean" and then reinstalling.
> I have tried deleting and recreating the install directory.
> I am using Gentoo with a linux kernel of 2.6.10 on a dual-Xeon 3.2ghz
> 64-bit system.
> Any other ideas would be helpful.  Thank you.
> -------------------- End of forwarded message --------------------


More information about the wine-devel mailing list